ASE Home Page Products Download Purchase Support About ASE
ChartDirector Support
Forum HomeForum Home   SearchSearch

Message ListMessage List     Post MessagePost Message

  Zip format?
Posted by ML on Aug-02-2019 22:50
Hi there, I've been using your software for years, but recently my VM bootstrapping script has been failing when it tries to install chart director. I use this snippet:

# Downloading Chart Director Module
curl -o /tmp/chartdir_php_linux_64.tar.gz http://download2.advsofteng.com/chartdir_php_linux_64.tar.gz &> /dev/null

# Extracting Chart Director Module into PHP modules directory
tar xvfz /tmp/chartdir_php_linux_64.tar.gz -C /usr/lib64/php/modules ChartDirector/lib --strip-components=2 &> /dev/null
rm -f /tmp/chartdir_php_linux_64.tar.gz


This has worked fine for years.

Recently, however, it's been failing with the following message:

gzip: stdin: not in gzip format

Any ideas?

  Re: Zip format?
Posted by Peter Kwan on Aug-03-2019 00:18
Hi ML,

It is because the URL has changed.

Some popular browsers nowadays will display an "insecure" icon if the URL does not use "https". To satisfy the browsers, we have changed our web site to use "https". "https" means the web is secured with a digital certificate. Our certificate is issued under the hostname "www.advsofteng.com".

If you use http://download2.advsofteng.com, it will be redirected to "https://download2.advsofteng.com". The browser will then warn about hostname not matching the certificate. If you ignore that warning and go ahead, it probably can still work.

However, for curl, it may or may not support the redirection, and if the certificate does not match the hostname, it may refuse to download. To solve the problem, try to use the following URL instead:

https://www.advsofteng.com/chartdir_php_linux_64.tar.gz

Hope this can help.

Regards
Peter Kwan

  Re: Zip format?
Posted by ML on Aug-04-2019 12:57
Wonderful, that worked perfectly. Thank you!


cix porn hard porn kostenlose porn amateur xxx love porn amateur sex hd porn free 3 xxx moblie porn